Computer Hardware Forum - TweakPC

Computer Hardware Forum - TweakPC (https://www.tweakpc.de/forum/)
-   Festplatten und Datenspeicher (https://www.tweakpc.de/forum/festplatten-und-datenspeicher/)
-   -   Problem mit Silicon Image SiI 3512 Controller (https://www.tweakpc.de/forum/festplatten-und-datenspeicher/75072-problem-silicon-image-sii-3512-controller.html)

NotANerd 09.02.2010 12:40

Problem mit Silicon Image SiI 3512 Controller
 
[U]Hallo,[/U]

ich habe ein Problem mit dem [B]Silicon Image SiI 3512 Controller[/B]. Nachdem ich ihn in den Rechner verbaut und den Treiber installiert habe, dachte ich ich könnte einfach 2 werksneue S-ATA-Platten dran hängen und sie als Daten-Platten nutzen. Der Treiber scheint auch korrekt installiert zu sein. Das System läuft auf einer (älteren) IDE-Platte und das würde ich auch gern so lassen. Das BIOS des Controllers zeigt die Platten zwar an, aber Windows nicht und das BIOS des Rechners ebenfalls nicht. Wenn die S-ATA-Platten angeschlossen sind, startet der Rechner erst und bleibt in einem Black-Screen stehen, wenn er eigentlich Windows booten sollte.

Wer kann mir helfen?
Was muss ich noch beachten und einstellen? :?

Rechner: AMD Duron 1200 MHz
Board: ECS K7SEM
System: Win XP Prof SP III
S-ATA-Platten: Samsung HD154UI
[I](ist nur ein Zweit-Rechner, der als Ablage dienen soll)[/I]

Danke im Voraus für Hilfe. :)



P.S.: Das kleine Manual und die Suche im Netz konnten mir nicht weiter helfen. :(

DaKarl 09.02.2010 12:47

AW: Problem mit Silicon Image SiI 3512 Controller
 
Wenn die Platten neu sind, musst du sie wohl erstmal Partitionieren

NotANerd 09.02.2010 12:52

AW: Problem mit Silicon Image SiI 3512 Controller
 
Schon klar, dass ich das tun müsste. :?

Wie gesagt, der Rechner bootet nicht mehr - sobald ich sie S-ATA-Platten angeschlossen habe. Wenn ich sie nicht angeschlossen habe, fährt das System regulär hoch.

Kann es sein, dass der Rechner von den neuen Platten booten will?

Und wenn ja, was kann ich tun? Das BIOS erkennt die Platten wie gesagt nicht, dort ist eingestellt dass er von der IDE-Systemplatte booten soll. :(

Oder gibt es andere Möglichkeiten?

DaKarl 09.02.2010 13:00

AW: Problem mit Silicon Image SiI 3512 Controller
 
[quote=NotANerd;663991]Das BIOS des Controllers zeigt die Platten zwar an, aber Windows nicht[/quote]
Wenn Windows nicht bootet woher weißt du dann dass die Platten in windows nicht angezeigt werden? *rätselhaft* :confused:

Auf jedenfall liegt es an der Bootreihenfolge ja.
Bei mir ist es so, dass im BIOS ein "bootable RAID Controller device" auftaucht, sobald ein Controller installiert ist. Das muss dann eben eine niedrigere Priorität bekommen. Oder wenn das nicht geht mal "boot other device" deaktivieren.

NotANerd 09.02.2010 13:19

AW: Problem mit Silicon Image SiI 3512 Controller
 
[quote=DaKarl;664003]Wenn Windows nicht bootet woher weißt du dann dass die Platten in windows nicht angezeigt werden? *rätselhaft* :confused:.[/quote]

Ja, stimmt. Sorry, das Windows fährt nur hoch, wenn die Platten nicht dran sind. :? Mein Fehler, sorry.

Ich finde im BIOS keinen "bootable RAID Controller device" und die Boot-Reihenfolge habe ich nun auch durchgetestet. Aber das nützt auch nichts, denn das BIOS erkennt die neuen S-ATA-Festplatten ja nicht. :(

Andere Idee? Ein Treiber für die Platten Samsung HD154UI? Muss da was gejumpert werden? Dächte es ginge ohne? :( Bin ratlos, es will einfach nicht.

vcmob 09.02.2010 13:22

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
im BIOS werden die Platten nicht angezeigt werden. Die siehst du nur in der Controller Meldung. Versuch mal bitte die Platten vom Controller zu entfernen, und den Controller im Rechner lassen. Nur um sicher zu gehen, dass Windows mit dem Controller bootet. Sie Silicons machen immer mal Probleme mit bestimmten Boards.

Evtl. auch Rechner-Bios und Controller-BIOS mal auf den neuesten Stand bringen. Steckplatz tauschen kann auch ein Mittel sein.

So grad mal nachgesehen, der SiI 3512 ist ein SATA1-Controller. Bestimmte SATAII-Platten bekommen das Auto-Detect nicht hin und zicken dann rum. Dazu hast du an den Platten einen Jumper wo du die hart in den SATAI-Modus schalten kannst.

Ciao MoB

NotANerd 09.02.2010 15:19

AW: Problem mit Silicon Image SiI 3512 Controller
 
Sobald ich die Platten vom Controller trenne, fährt das System normal hoch.

Jetzt habe ich den Controller-Treiber nochmal gecheckt und bin zumindest soweit, dass das System mit angeschlossenen Platten hochfährt. [I](An den BIOS-Treiber trau' ich mich nicht so recht ran.)[/I] Der Raid-Controller zeigt mir beim Booten an, dass er die 2 Platten als "[B]SiI Stripped Set[/B]" erkennt. Dann startet Windows erstmal.

Dann habe ich [B]"diskmgmt.msc"[/B] gestartet, in der Hoffnung dass die Platten dort angezeigt werden. Leider war dem nicht so. :(

[quote]Dazu hast du an den Platten einen Jumper wo du die hart in den SATAI-Modus schalten kannst.[/quote]Auf der Rückseite der Platten sind zwar 4 PINs, aber es gibt keine Anleitung was sie bedeuten und wozu sie dienen sollen. Ist auch kein Jumper dran.

Wie gehe ich weiter vor? :?

vcmob 09.02.2010 15:29

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
Jumperbelegung:
[url]http://downloadcenter.samsung.com/content/UM/200510/20051010165142468_3.5_SATA_eng_r4.pdf[/url]

Hast du den Treiber für den Controller schon installiert? Wird der SIL im Gerätemanager korrekt angezeigt?

Ciao MoB

NotANerd 09.02.2010 15:39

AW: Problem mit Silicon Image SiI 3512 Controller
 
[quote=vcmob;664036]Hast du den Treiber für den Controller schon installiert? Wird der SIL im Gerätemanager korrekt angezeigt?[/quote]
Ja - ich habe den Treiber installiert und er wird im Gerätemanager ohne "?" oder ähnliches angezeigt. Außerdem steht da, dass der Controller aktiv ist. Ich gehe davon aus, dass er funktioniert.

[I]Zum Jumper:[/I] Bei meiner HD sind es nicht 4 PIN-Paare, sondern nur 2. :-o
Ich finde keine Anleitung dazu, außerdem ist kein Jumper gesetzt bzw. enthalten.



[I]P.S.: Ich habe mal eine 500-GB-SATA dran gemacht statt der 2 1,5-TB-Platten. Dort startete das System wiederum nicht. Auch ein Jumper-Problem?[/I]

vcmob 10.02.2010 08:00

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
hast du für die 500er Platte die Jumper-Belegung? Für die großen finde ich auf die schnelle auch nix. Aufgedruckt ist auch nix?

Ciao MoB

NotANerd 10.02.2010 08:58

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hallo,

die besagte 500-GB-Platte ist eine [B]Maxtor DiamondMax 22 500GB (STM3500320AS)[/B], die vorher ebenfalls nur als Daten-Platte (also Slave) lief. Von der aufgedruckten Jumper-Beschreibung kann ich nur entnehmen, dass dort eine [I]"Limit to 1.5GB/s Operation"[/I] eingestellt ist. Inwiefern das Relevanz hat weiß ich leider nicht. :(

Die beiden 1.5TB Samsung HD154UI habe ich wie gesagt nochmal angeschlossen und das Controller-BIOS zeigt sie auch beim Booten als "[B]SiI Striped Set"[/B] an. Nach der Treiberaktualisierung des Controllers startet der Rechner mit diesen beiden Platten komischerweise sogar regulär. Im Windows XP Prof SP III werden sie jedoch nicht angezeigt, auch nicht im "[B]diskmgmt.msc[/B]". :?

Sehr seltsam, dass sie nun plötzlich angezeigt werden aber die 500GB-Platte nicht.

vcmob 10.02.2010 09:41

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
deine 500er Platte ist hart in den SATA1 Modus geschalten. Das ist auch die Einstellung die du an den großen Platten vornehmen solltest.

Im Controller-Setup (Tastenkombination steht immer da CTRL+???) solltest du die Platten nicht als Stripped-Set laufen lassen sondern einfach als Festplatten.

Mit der Aussage "Sehr seltsam, dass sie nun plötzlich angezeigt werden aber die 500GB-Platte nicht. " kann ich leider nix anfangen.

Ciao MoB

NotANerd 10.02.2010 11:16

AW: Problem mit Silicon Image SiI 3512 Controller
 
Wenn die 500GB-Platte auf S-ATA 1 geschaltet ist, warum fährt dann dort das System nicht hoch? 8-O

Leider habe ich auch keine Idee wie ich die 1,5TB-Platten auf S-ATA 1 schalten soll. :(

Ich habe nun erstmal im Controller-Setup das "Striped Set" raus genommen. Die 1,5TB-Platten stehen nun einzeln als "0" und "1" da.
Nur fährt nun das System nicht mehr hoch. :(

Kann es sein, dass er nun versucht von einer der beiden Platten zu booten? Ich habe jedoch im Rechner-BIOS die Boot-Priorität gecheckt und versucht einzustellen dass er von der normalen System-IDE-Platte startet. Dort wird ja auch nur diese eine angezeigt, aber als IDE Secondary Master. Ich bekomme nicht eingestellt, dass die HD als IDE Primary Master eingetragen ist. Kann es daran liegen? Und wenn ja - wie kann ich die eingebaute IDE-Platte als IDE Primary Master setzen?

Mit [I]"Sehr seltsam, dass sie nun plötzlich angezeigt werden aber die 500GB-Platte nicht."[/I] wollte ich sagen dass es mich wundert dass das System mit den eingebauten 1,5-TB-Platten im Striped Set hoch fuhr, aber mit der 500GB-Platte einzeln nicht.

vcmob 10.02.2010 11:43

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
du solltest dich mal präziser ausdrücken. Wichtig ist, WO das System nicht hochfährt. Bleibst du schon vor dem Windows hängen oder erst nachdem der Ladebalken kommt?.

Vor Windows > BIOS versucht von den Platten zu booten.
Ladebalken > Controller bzw. SATA-Jumper sind schuld.

Die IDE Platte muss auf Master gejumpert sein und am Primären IDE Kanal angeschlossen werden. Boot-Priorität muss auf diese Platte eingestellt werden.

Ciao MoB

NotANerd 10.02.2010 16:52

AW: Problem mit Silicon Image SiI 3512 Controller
 
T'schuldigung, dass ich so viel Mühe/Umstände bereite. :?

Der Rechner bleibt [U]VOR[/U] Windows hängen, es erscheint kein Ladebalken.
Er startet, zeigt dann den SiL-Controller an (der auch die beiden HDs auflistet) und stoppt dort, wo er Windows laden müsste mit dem besagten Blackscreen.

Habe nochmal gecheckt: Die IDE-System-Platte ist auf Master gejumpert, mittlerweile habe ich sie wieder durch Umstecken der Kabel als [B]IDE Primary Master[/B] einragen können. Die Boot-Priorität ist auch auf diese Platte eingetragen. :(

Was kann ich noch versuchen? :|

vcmob 11.02.2010 06:54

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
irgendwas stimmt da bei dir nicht.Ich würde wirklich mal beim Board und beim Controller das BIOS aktualisieren.

Ciao MoB

NotANerd 11.02.2010 14:59

AW: Problem mit Silicon Image SiI 3512 Controller
 
[quote=vcmob;664413]irgendwas stimmt da bei dir nicht.[/quote]

Ja, habe auch das Gefühl. :?

Das SiI3512-Controller-Treiber habe ich laut Gerätemanager (wenn die Platten nicht dran sind kann ich das dort ja einsehen) auf Version 1.0.62.0. Beim Starten des Rechners wird allerdings "SiI 3512A SATARaid BIOS Version 4.3.79" angezeigt. :?

Vom BIOS des Mainboard [B] ECS K7SEM[/B] habe ich zwar ein Update gefunden, trau' mich aber nicht das zu installieren.


Vielleicht kannst Du mir einen Tipp geben woher ich aktuelle und vor allem seriöse Updates beziehen kann?

NotANerd 15.02.2010 15:21

AW: Problem mit Silicon Image SiI 3512 Controller
 
Update:

Das BIOS des Rechners habe ich flashen können, es ist nun die laut Elitegroup neuste Version drauf.

Beim 3512-Controller habe ich von der Website [URL="http://www.tweakpc.de/forum/%28http://www.siliconimage.com/support/searchresults.aspx?pid=29&cat=15%29"](http://www.siliconimage.com/support/searchresults.aspx?pid=29&cat=15)[/URL] das aktuelle BIOS geladen, bekomme es aber nicht zum Laufen. Das "Update Utility" macht wohl nicht ganz was es soll.

Wie wende ich das neue BIOS (****.bin) des Controllers ohne das Update-Utility an? [IMG]http://www.supernature-forum.de/images/smilies/frown.gif[/IMG]


[URL="http://www.tweakpc.de/forum/%28http://www.siliconimage.com/support/searchresults.aspx?pid=29&cat=15%29"][/URL]

vcmob 19.02.2010 17:33

AW: Problem mit Silicon Image SiI 3512 Controller
 
Hi,
sorry war im Urlaub. Ohne das Update Utility wird das nix. Evtl. kannst du mal im BIOS des Controlers nachsehen ob es da eine Update option gibt. Ansonsten hast du vll. eine Board/Controler-Kombination wo das Teil nicht will.

Ich würde mal schauen ob du die Platten in den SATA-I Modus bekommst.

Ciao MoB

NotANerd 22.02.2010 08:55

AW: Problem mit Silicon Image SiI 3512 Controller
 
Das Problem ist gelöst.

BIOS-Update des Mainboards und BIOS-Update des Controllers brachten nun alles zum Laufen. Beides mit Boot-CD ausgeführt und ich kann den Controller und die Festplatten nutzen.

Danke an alle Poster und Helfer. :-D


Alle Zeitangaben in WEZ +1. Es ist jetzt 21:02 Uhr.

Powered by vBulletin® Version 3.8.10 (Deutsch)
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2 ©2010, Crawlability, Inc.